Comment by throw0101a
5 hours ago
> I would wager that almost no Linux installs are done by CD or displaying VGA anymore (maybe 0.01%).
When one of your Proxmox (or XCP-ng, or VMware/Nutanix/OpenStack) servers won't boot and you need go into single-user/rescue mode, then talk to me about the convenience or not of a remote KVM (versus having to drive to the DC and hook up the crash cart).
It's all very well if all you manage is VMs/instances, but some of us deal with the hardware that those VMs run on, and things break.
That 0.01% of servers is probably the layer that the other 99.99% run on (and yes, a lot of that 0.01% can also be automated, but if PXE isn't working (or you're getting strange CPU3VOLT or SLOT17ECC or BUS1RESET errors) then neither is re-imaging).
The alternative isn't driving to the DC; it's remote serial console through a console server or the BMC.